Minimum Specifications & Supported Devices for Premium

Current List of Supported Devices for Pandora Premium

Pandora Premium is available only on iOS and Android phones that meet our minimum specification guidelines.

 

Minimum Specifications for Pandora Premium

 

Minimum Specs for iOS:

 

The current version of Pandora for iOS requires iOS 9.

 

To confirm the iOS version you are running on your device, open Settings > General > About> and Version.

 

If you are running an iOS version older than 9.0, you will need to update your device's operating system (iOS). Please refer to this article on how to do that:http://support.apple.com/kb/HT4972

 

If you are using an older iOS device that is not able to upgrade to iOS 9, you should be able to download a previous version of the Pandora app from the iTunes store if:

 

 

Minimum Specs for Android:

 

On Android devices, the current version of Pandora requires KitKat 4.4 or higher.

 

To confirm the Android version you are running on your device, open Settings, General, About Device, and Android Version.

 

If you are running an Android OS version older than KitKat 4.4, you will need to update your device's operating system.

 

For some Android devices, you can update by going to Settings > General> About device > Software updates > Check for update.

 

If you are using an Android device that is not able to upgrade to KitKat 4.4 or higher, you should be able to download a previous version of the Pandora app from the Google Play store. Otherwise, you won't be able to download Pandora on that device.

 

Back To Top

 

__________________________________________________________________________




Not what you're looking for? Try searching again or Email Us.

Pandora Premium