Minimum Specifications & Supported Devices for Premium

Pandora Premium is available only on iOS and Android devices that meet our  minimum specification guidelines.

 

Minimum Specs for iOS:

 

The current version of Pandora for iOS requires iOS 10.

 

To confirm the iOS version you are running on your device, open Settings > General > About> and Version.

 

If you are running an iOS version older than iOS 10, you will need to update your device's operating system. Please refer to this article to learn more. 

 

Minimum Specs for Android:

 

On Android devices, the current version of Pandora requires Lollipop 5.0 or higher.

 

To confirm the Android version you are running on your device, open Settings, General, About Device, and Android Version.

 

If you are running an Android OS version older than Lollipop 5.0, you will need to update your device's operating system.

 

For some Android devices, you can update by going to Settings > General> About device > Software updates > Check for update.

 

Back To Top

 

__________________________________________________________________________




Not what you're looking for? Try searching again or Email Us.

Pandora Premium